JQuery conflict with my theme Status:

Home Forums Thumbnail Scroller (WordPress Plugin) JQuery conflict with my theme

This topic is: resolved

This topic contains 18 replies, has 2 voices, and was last updated by  Marian 2 years, 7 months ago.

Viewing 19 posts - 1 through 19 (of 19 total)

  • I’m using a modified Twenty Eleven theme v. 1.9, and I have Sugar Slider installed on my site as well. The Sugar Slider and Thumbnail scroller are conflicting with one another. I can get the Sugar Slider to work if I turn off JQuery via the settings for Sugar Slider (they have a check box if there are conflicts to turn it off). But when I do that then the Thumbnail scroller doesn’t load. If I uncheck that box then the scroller works, but the Sugar Slider doesn’t work. Can you help? Here is the code from my header.php file, URLs to the affected pages follow at the end:
    <head>
    <meta http-equiv=”Content-Type” content=”text/html; charset=utf-8″ />
    <title>Industrial Realty Group, LLC</title>
    <link rel=”stylesheet” type=”text/css” media=”all” href=”<?php bloginfo( ‘stylesheet_url’ ); ?>” />

    <!–<script type=’text/javascript’ src=’http://ajax.googleapis.com/ajax/libs/jquery/1.4.4/jquery.js?ver=1.4.4′></script>
    <script type=’text/javascript’ src=’http://industrialrealtygroup.com/wp-content/plugins/sugar-slider/includes/js/jquery.sexyslider.js?ver=3.4.2′></script>
    <script type=’text/javascript’ src=’http://industrialrealtygroup.com/wp-content/plugins/sugar-slider/includes/js/slidedeck.jquery.lite.js?ver=3.4.2′></script> –>
    <?php if (!wp_script_is(‘jquery’, ‘queue’)){
    wp_enqueue_script(‘jquery’);
    }
    wp_head();?>
    </head>

    homepage with Sugar Slider: http://www.industrialrealtygroup.com
    subpage with Thumbnail Scroller: http://www.industrialrealtygroup.com/public-private-partnerships

    Currently I have the sugar slider working and the thumbnail scroller not working.
    Thanks for your hlep!



    Marian Support Team #30473

    Hello

    Please send us your ftp info (as private reply ) to fix your problem.

    Best Regards,
    Support Team

    • This reply was modified 2 years, 7 months ago by  Marian.


    This reply content has been deleted.

    This is an automatic action, which occurs after a week, if the user provided sensitive information in a private reply.



    Marian Support Team #30508

    Hello

    Please remove ( not comment ) this line from your header.php

    and then will works.

    Best Regards,
    Support Team



    I did as requested, no change, thumbnail scroller still now showing.



    Marian Support Team #30546

    Hello

    Do you use a CDN server or you have a cache plugin ? because i’ve seen that is still there.

    Best Regards,
    Support Team

    • This reply was modified 2 years, 7 months ago by  Marian.


    No, nothing like that. I’m viewing the code of the page via Firefox’s “View page source” and I can see that that line has been removed. The two lines for the sugar-slider are still there, but I need those for the slideshow on the homepage, right?



    I have now removed the other two lines for sugar-slider, the slider still works, but the thumbnail scrollers still do not load.



    Marian Support Team #30581

    Hello

    Can i make few changes into your theme to fix your problem ?

    Best Regards,
    Support Team



    Yes, please do. Please let me know which files you change and if you can add comment lines that would be great too. The reason being is that I’m transitioning to a revised theme in the very near future and I don’t want to have the same issues. The current theme is “IRG_theme”. Thank you for your help!



    Marian, is there anything I can do on my end to get this going? My client is getting a bit anxious. Thanks!



    Marian Support Team #30776

    Hello

    I found your problem but i need also your wp-admin info to fix it.

    Best Regards,
    Support Team

    • This reply was modified 2 years, 7 months ago by  Marian.


    This reply content has been deleted.

    This is an automatic action, which occurs after a week, if the user provided sensitive information in a private reply.



    Hi Marian…have you had any luck? Were you able to log into our site?
    Thanks.



    Marian Support Team #31020

    Hello

    I’ve tried to login to your wp-admin but it doesn’t authenticate me.

    Best Regards,
    Support Team



    This reply content has been deleted.

    This is an automatic action, which occurs after a week, if the user provided sensitive information in a private reply.



    Marian Support Team #31124

    Hello

    Fixed. The problem was from your theme and from sugar slider.

    First of all i disabled jquery from sugar.
    Secondly i moved the code

    from header.php to functions.php ( because jquery was loaded after your sugar slider and always must load before of all plugins).

    Best Regards,
    Support Team



    PERFECT! Thank you so much!!
    Dave



    Marian Support Team #31130

    Hello

    Glad i could help to you. If you like our item and support please don’t forget to give us 5 stars on Codecanyon ( http://codecanyon.net/downloads )

    Best Regards,
    Support Team


Viewing 19 posts - 1 through 19 (of 19 total)

The topic JQuery conflict with my theme is closed to new replies.